1988RedT2
1988RedT2 MegaDork
9/13/22 11:29 a.m.

So, the E39 530i soldiers on.  It has met the needs of both my sons as their first car.  Son #2 continues to daily it, and he enjoys it very much.

From the very first time I looked under the hood--so, three years ago?--it has had a bit of oily mess on the power steering reservoir.  Level is always at full, never over.  Cap is tight.  If I wipe it clean, it will be back after awhile. 

No obvious leaks.  What's going on?  Or is this normal?

 

res

enginenerd
enginenerd Reader
9/13/22 11:42 a.m.

My E39 always looked like that as well. IIRC there's an O-ring under that cap you can replace

Slippery
Slippery PowerDork
9/13/22 11:46 a.m.

There is a tiny hole on the cap. Look closely and you will see it. There is a built in filter in the reservoir, maybe a new one fixes the problem. They are not expensive iirc. 

AngryCorvair (Forum Supporter)
AngryCorvair (Forum Supporter) MegaDork
9/13/22 11:46 a.m.
enginenerd said:

My E39 always looked like that as well. IIRC there's an O-ring under that cap you can replace

Yeah, this. You can carefully remove the existing o-ring and flip it over as an experiment, or you can replace the o-ring with new for $2. 

GameboyRMH
GameboyRMH MegaDork
9/13/22 11:47 a.m.

I noticed that my AE92's PS tank similarly accumulates grime without any leaks or other malfunctions, it may be that when the fluid does spill on the outside during fluid changes etc it makes the tank extremely sticky even after you wipe it up, so grime sticks to it. Maybe try cleaning with alcohol or brake cleaner and see if there's any difference?

02Pilot
02Pilot UberDork
9/13/22 11:54 a.m.

The cap has a vent hole. If it gets plugged, and the O-ring is compromised, the fluid gets pushed out. I'd suggest buying a new cap at a minimum, or better the whole reservoir; there's a filter in the bottom, and it's probably well past due.

Slippery
Slippery PowerDork
9/13/22 12:03 p.m.

1988RedT2
1988RedT2 MegaDork
9/13/22 12:07 p.m.

Very good, gentlemen, and thanks!

Looks like a new reservoir is in her future.  I will check the vent hole when I see the car this afternoon.

jgrewe
jgrewe HalfDork
9/13/22 1:04 p.m.

I had the same thing on my wagon when I got it. I replaced the cap and problem was solved.

Now I have to look closer to see about that filter I didn't know about.

psteav (Forum Supporter)
psteav (Forum Supporter) Dork
9/13/22 1:25 p.m.

Yeah, they all do that.  Also, your cupholder is broken.

1988RedT2
1988RedT2 MegaDork
9/13/22 4:43 p.m.
psteav (Forum Supporter) said:

Yeah, they all do that.  Also, your cupholder is broken.

No, tisn't either!

I think literally the first thing my elder son did when we got the car was install an aux jack so he could play music off his phone, and install this:

https://www.amazon.com/PREMIUM-FRONT-HOLDER-528i-525i/dp/B01DOSEMV2/ref=sr_1_3?keywords=bmw+e39+cup+holder&qid=1663101644&sr=8-3

pic

Our Preferred Partners
QyfS7JdHC83pBAkZ9Wu9Y3PU6ujaIo7YsIUNVgn7ywqmF9Q4PyQnz4lOLuRamUBr