3 4 5 6
Scotty Con Queso
Scotty Con Queso SuperDork
8/21/22 1:29 p.m.

Until then, driveway idle. 
 

 

Scotty Con Queso
Scotty Con Queso SuperDork
8/21/22 3:44 p.m.

I drove it. Runs like pickled E36 M3. I'm tired of working on it. Feels like it's running on 5 cylinders. Any advice on where to start? 

Mr_Asa
Mr_Asa UltimaDork
8/21/22 3:51 p.m.

In reply to Scotty Con Queso :

Can you hook up a computer?  If not, use a laser temp gauge (and if you don't have that, a water bottle that squirts water) to check temps of each cylinder after it gets hot enough to warm the exhaust.

Verify its running on X cylinders, move on from there.

Scotty Con Queso
Scotty Con Queso SuperDork
8/21/22 4:08 p.m.

In reply to Mr_Asa :

I did the water bottle trick and it seems to be burning all cylinders. 

Computer through oBD dongle is saying multiple misfires on multiple cylinders. 

Bad gas maybe? Been sitting since January. When it's idling and I give it throttle it just doesn't seem to want to take it. Won't really rev. Same under load. 

solfly
solfly Dork
8/21/22 5:59 p.m.

Check coils and plug wires? Swap them around and see if the misfires move?

Scotty Con Queso
Scotty Con Queso SuperDork
8/21/22 7:44 p.m.

Going to start with taking the plugs out to inspect. One thing I've read on some old forum threads is from people LS swapping engines that have set. Modern gas turns to powder in the injectors and they go bad fast. Apparently one easy way to see a bad injector is to compare it the corresponding plug. 

Scotty Con Queso
Scotty Con Queso SuperDork
8/26/22 9:54 a.m.

I think the worst thing about getting a project car running is dealing with the issues that arise. On Monday or Tuesday maybe I went to move the truck and my compression fitting on the high pressure line noped itself and sprayed power steering fluid everywhere. Great.

Injector cleaning kit coming tomorrow hopefully. Still really want to drive this thing at full capability. 

Scotty Con Queso
Scotty Con Queso SuperDork
8/27/22 5:14 p.m.

TIL: LS truck injectors go bad easily. Bought a cheap cleaning rig from eBay. The one you hook up to brake cleaner and a battree. 2 injectors were barely opening and wouldn't spray. I think the coils inside the injectors were. Bad. I had 6 spare injectors. 4 of those. Also bad. 

RacetruckRon
RacetruckRon Dork
8/27/22 5:37 p.m.

In reply to Scotty Con Queso :

An ultrasonic cleaner bath and blowing air with a compressor back through the pintle can help clear them out sometimes as well.  Those solenoids are cycle tested so much it's very rare for OEM injectors to have a true failure like that. They are normally stuffed up with Ethanol gunk from sitting in my experience. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) UberDork
8/28/22 1:33 p.m.

In reply to RacetruckRon :

+1000 on this. I have seen them gummed up from the ethanol in low as 3 months. 

nsogiba
nsogiba New Reader
8/29/22 1:11 p.m.

Hey you're almost there! At least now any little fixes can be immediately enjoyed through the instant gratification of a small test drive. 

If you don't have HPTuners to log, you can verify commanded/actual timing through some cheap OBD2 apps that are available for free. Also, a wideband will really help you determine if it's rich/lean. I can't remember if you already had the PCM unlocked (VATS remove) but the stock truck tunes are pretty bogged down from the factory, they respond nicely to removal of torque management and enabling power enrichment. 

One step closer to burnouts!

Lof8 - Andy
Lof8 - Andy SuperDork
8/29/22 2:17 p.m.

Cool truck!  I just read the whole thread.  In to see it running well!

OneSickGNX
OneSickGNX Reader
8/30/22 7:11 p.m.

Glad to see your progress. If it still has a miss after you clean the injectors you might want to try unplugging the maf. It will put the computer into open loop and can help you determine if it's a hardware or tuning issue.

Scotty Con Queso
Scotty Con Queso SuperDork
9/1/22 2:25 p.m.

Got the new power steering line put in and got the now cleaned injectors back in. It now runs a ton better - in closed loop. Drove it around the neighborhood and it did the exact same thing. Stumble, wouldn't idle.  I barely got in back in the driveway. 

In summary, it's running like crap in closed loop. That leads me to think o2 sensor. I'll log it tonight in hopes that cures it. 

Scotty Con Queso
Scotty Con Queso SuperDork
9/5/22 8:42 p.m.

Dug into the codes I was getting and noticed a P0200 for injector circuit malfunction. Got a test light and I wasn't getting switched ground to injector 5. Went tracing the wire at the ECU and boom. This caused me a lot of problems:

See that pin that's pushed in? That's the #5 switched ground. Popped that back in and started the truck. It ran excellent! Reved awesome. Drove it around the neighborhood. Need to check everything over before a road test. 

Scotty Con Queso
Scotty Con Queso SuperDork
9/6/22 4:13 p.m.
Scotty Con Queso said:

I drove it. Runs like pickled E36 M3. I'm tired of working on it. Feels like it's running on 5 cylinders. Any advice on where to start? 

This is funny now. Turns out I was running without cylinder 5. 

RacetruckRon
RacetruckRon Dork
9/6/22 6:00 p.m.

Great success! Does it do a burnout? We obviously need video proof... filmed in Mexico of course.

nsogiba
nsogiba New Reader
9/7/22 11:52 a.m.

 

Sometimes it's just silly little things. Free fix! Burnout time!

 

AngryCorvair (Forum Supporter)
AngryCorvair (Forum Supporter) MegaDork
9/7/22 3:18 p.m.

i heard LS swapped Colorados won't spin the tires even a little bit.

RacetruckRon
RacetruckRon Dork
9/7/22 3:24 p.m.

I'm hoping to hear what you think of the AR5 and fabbot adapter.  I'm really fed up with the clutch in my CD009 swap.

Scotty Con Queso
Scotty Con Queso SuperDork
9/7/22 8:42 p.m.

In reply to AngryCorvair (Forum Supporter) :

Well you heard right. About this one anyway. Drove on the road last night. It still ran like E36 M3.  Didn't want to take throttle and was stuttering and missing. Drove back home and these are my codes:

Yep. Still misfiring. Digging into the IAC code coupled with misfire made me think vacuum leak. Sprayed the heck out of the top end with starter fluid and there are no leaks. I don't freaking know at this point. Pull the plugs maybe? 

AngryCorvair (Forum Supporter)
AngryCorvair (Forum Supporter) MegaDork
9/7/22 9:28 p.m.

In reply to Scotty Con Queso :

Vacuum leak at brake booster?

Scotty Con Queso
Scotty Con Queso SuperDork
9/8/22 7:47 a.m.

In reply to AngryCorvair (Forum Supporter) :

No leaks there. I did realize that I can use my scanning app to read misfire counts on each cylinder. Going to start there and go down the rabbit hole of changing around plugs/wires/coils/injectors. 

RacetruckRon
RacetruckRon Dork
9/8/22 3:13 p.m.

I'm hoping its something simple causing that misfire but a couple things outside of the obvious plugs and wires.  This is a cheap chinese swap harness no?  Are the individual coils or the coil bank connectors wired incorrectly? If the triggers or switched grounds were flipped around it could be an issue.

Another thing how is the health of the battery? Low voltage can cause those heatsink coils to act goofy.  Are the dwell settings in the tune setup for those coils?  I didn't think that was normally a big deal but I know those heatsink coils can act quite a bit differently in some cases than the LS3 or older truck style coils.

Scotty Con Queso
Scotty Con Queso SuperDork
9/20/22 3:00 p.m.

After some digging and diagnostics, I don't really have a misfire. The tune I have is a startup tune and really that's about all its good for. I'm going to start saving for a Terminator X since I don't plan to buy HP Tuners or pay $1000 for a dyno tune when in the end I want to go turbo anyhow. 

3 4 5 6
Our Preferred Partners
OtoPwGsvDHfj32fbS9oKgHTRdsv6iXEGL8YXZ2TQrTLqC96AA0I40aMgSw95lifD